Spark Problems

Nerevar

New Member
Oct 9, 2008
27
0
0
Pennsylvania, USA
I recently determined my CDI and magneto were bad so I replaced both. Now with the replacement parts installed I only have spark with the plug out while i'm holding the plug... :-|| which shocks me mind you... HELP PLEASE!!!
 

biken stins

New Member
Jul 11, 2008
156
0
0
If your getting bit when it's out, should mean it is sparking in engine. Did you change plug and wire ? Wire may have a break in it when positioned different. Is is getting fuel. What kind of engine ?
Hang in there.
 

spad4me

New Member
Jan 20, 2008
472
0
0
Arizona Bullhead
How did you determine the cdi was bad?
Do not allow the plug to spark ungrounded.
With the sparkplug wire connected to the plug. Firmly press the threaded part to the bare metal cooling fin while watching the spark plugs GAP. Now let the clutch out. Gently push the bike forward. Did you see a spark??? Keep trying until you either see a spark or you are sure you did NOT .
You will probably wind up buying another cdi.
 

Nerevar

New Member
Oct 9, 2008
27
0
0
Pennsylvania, USA
If your getting bit when it's out, should mean it is sparking in engine. Did you change plug and wire ? Wire may have a break in it when positioned different. Is is getting fuel. What kind of engine ?
Hang in there.
Yeah i purchased a high performance plug and wire. It is getting fuel... I can smell it when i push the bike with the plug out. It is an 80cc Chinese engine from BoyGoFast.
 

Nerevar

New Member
Oct 9, 2008
27
0
0
Pennsylvania, USA
How did you determine the cdi was bad?
Do not allow the plug to spark ungrounded.
With the sparkplug wire connected to the plug. Firmly press the threaded part to the bare metal cooling fin while watching the spark plugs GAP. Now let the clutch out. Gently push the bike forward. Did you see a spark??? Keep trying until you either see a spark or you are sure you did NOT .
You will probably wind up buying another cdi.
I tested the CDI and magneto with a meter and compared them with readings people got on this forum. I got open for all readings concerning the blue wire on both the CDI and magneto. Which would mean that they're both bad. I got back from work late today so I was unable to try your idea. If I don't get a spark does that mean the brand new CDI is bad? When it sparks while i'm touching the threaded part of the plug, my left hand which is holding the handlebar sometimes also gets shocked. I'm puzzled. I have the black wire of the magneto on the lower left screw that holds it in... is that correct?
 

toytime

New Member
Mar 20, 2008
550
0
0
Ontario
Seeing as you have the same problem as you began with, I would be asking myself if it was something else right from the start. Wiring?
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
236
63
up north now
If you are getting spark while grounding yourself to the bike, you are getting spark while the plug is screwed in.....
 
Last edited:

Nerevar

New Member
Oct 9, 2008
27
0
0
Pennsylvania, USA
Thanks for the help everyone I finally got it up and running yesterday. Only thing now is it runs kinda rough at full throttle - seems like it bogs down. Any ideas?
 

Tim Mills

New Member
Oct 9, 2009
66
0
0
42
Mississippi
Hi im a newbie an actually right now im in Iraq. when we got here a couple of guys had these kits which now a couple of guys in my group have them now. we are a maintenance team so you know we all tinker LOL. My kit should be coming this week thatsdax F80 the guys that have them now mixed the fuel way too thick at first now having issues they are running a little better now though. Anyways this is my question once youget going on either one of these bikes at about top speed they want to cut out let off the throttle an you go again could this be magneto getting wet or? Any feed back would be great plus any tips for installing my kit Thanks.xx.
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
236
63
up north now
Hi im a newbie an actually right now im in Iraq. when we got here a couple of guys had these kits which now a couple of guys in my group have them now. we are a maintenance team so you know we all tinker LOL. My kit should be coming this week thatsdax F80 the guys that have them now mixed the fuel way too thick at first now having issues they are running a little better now though. Anyways this is my question once youget going on either one of these bikes at about top speed they want to cut out let off the throttle an you go again could this be magneto getting wet or? Any feed back would be great plus any tips for installing my kit Thanks.xx.

Welcome to the forum. Your problem sounds like a fuel delivery issue.
 
Last edited:

BarelyAWake

New Member
Jul 21, 2009
7,206
9
0
Maine
I had similar symptoms and as Joe mentioned, it was a fuel problem - the float was set too low in the carb (on mine anyway).

Fuel starvation is weird - it can often feel like a different system havin' issues o_O
 

Nerevar

New Member
Oct 9, 2008
27
0
0
Pennsylvania, USA
I was having a similar problem w/my bike...Here's how it played out. Don't expect it to run 100% using the break-in fuel mixture. After you run the break in period and the fuel is thinned out to 24 or 32:1 it will run much stronger and have better top end. Don't go screwing with the carb until you try the normal fuel mixture. I messed up my carb doing this and had to order a new one. Also, a new high performance plug and wire will help too. Good luck!
 

aquarianmonkey

New Member
Sep 27, 2009
29
0
0
sedona Az.
Was reading these posts on spark I still run the same plug as supplied with the eng. but I purchaced a wire set for a 70 250 chevy with 90 degree boots seams to work good and the longer wires alow for coil location anywhere on the bike. I chased a rough running at wide open throttle on my bike thinking it was the carb it turned out to be the intake tube was loose in fact it sucked half the gasket in so I did remove the tube and cleaned the surface I reinstalled the the tube without a gasket and it runs great. The only problem now is my exhaust pipe I built broke so for now it has a 6 inch staight pipe till I can fix the other pipe. As I read on here someware if they can hear you they will see you LOL.shft.
 

Attachments