New to Forum. I have Titan XC Engine Kit

KAM

New Member
Jun 30, 2008
3
0
0
I am new to the forum. I have read several threads and found the information helpful and entertaining. With the insistance from a fellow motorized bike owner, I have decided to join the forum...

I have been riding my 1989 model Diamond Back bicycle with the Titan XC engine kit for a few days now. I have burned a little over a tank. I guess I have driven about 40 miles. I am pleased so far. I bought the kit so I could ride my bike to work and church which are both within 7 miles from home. I would appreciate some help with the following.

1. I have an oil leak that appears to be coming from the power take-off attached to the centrifugal clutch. What kind of oil goes in this little gearbox? Have others had this problem? I have tried to contact Dacs but no one has answered the phone in the past two days.
2. How long is the break in period for this motor? I am ready to run full throttle but do not want to do so too soon.
3. I have had to tighten the chain 5 times already. Should I be concerned?

Thanks in advance.
 

NunyaBidness

Active Member
Jun 29, 2008
1,062
1
38
memphis tn
hey KAM welcome to the site
I dunno bout your #'s 1+2, but #3 chains will 'stretch' with use, this is normal with a new chain as all the little parts are settling into place. You may need to take another link or two out before it is fully settled but give it some time by using the tensioner to increase tension. Some people just use the tensioner but I don't like the look and plan on having proper tension in my chain without a need for a tensioner. thats just my personal preference ymmv
good luck with your ride and I'm sure one of the more experienced folks will be around soon enough:ride2:
 

paul

Well-Known Member
Dec 23, 2007
5,548
39
48
63
Kalamazoo, MI
high kam. check on the motor below where you put the oil is a nut. tighten that. it is for draining the oil and i know i had to tighten mine, most likely the oil is coming out thier slow and apears to be dripping from the other part. if it is coming from the power take off i am not sure for i just went with what came with the kit. break in i am not sure. i have a couple hundred miles on mine and i never really babied it but i never keep at full throttle long distances. i try to keep changing it every so often. 3rd the chain. make sure everything is mounted secure and your mount is not moving. new chains do loosen for a while then finnally stop. try to email dax and see if you get an answer that way. i think he may be on the road but i am sure he is checking is email. hope that helps and glad to have you with us
 

KAM

New Member
Jun 30, 2008
3
0
0
Thanks for all the replies.

I reached Dacs by phone today and got my answers. The oil is weeping not leaking. It will stop when the oil reaches the proper level.

The break in period will last until 300-400 miles.
 

Skyliner70cc

Member
Mar 8, 2008
138
0
16
if you have an oil seal that is leaking, a good additive to use before replacing the seal is called auto-rx. This product has outstanding user reviews on BITOG (google it) and it saved me a ton of hassle in replacing a leaking rear main seal on my wife's 06 Jeep Liberty CRD.
 

Dave31

Moderator
Staff member
Mar 1, 2008
11,204
29
38
Aztlán, Arizona
Thanks for all the replies.

I reached Dacs by phone today and got my answers. The oil is weeping not leaking. It will stop when the oil reaches the proper level.

The break in period will last until 300-400 miles.
Thank's for letting us know Kam, now we can share that info with future members who have the save problem :)
:ride2:
 

Joshua

New Member
Jun 8, 2008
74
0
0
usa
kam how hard was it to mount that motor up, I'm looking at getting one sometime down the road. Let us know how it runs. Also, welcome and you won't be disappointed you joined, tons of help.