Help

Mrgreen

New Member
Aug 5, 2020
8
0
1
36
Yes I have a bike kit on my bike, now when I start out I have trouble keeping the gas going from tank to carburetor, it runs good, then starts to choke and eventually dies and I look and the gas line is empty, I have to open the gas lid off and flick the gas line by the carb. What would cause this and how can I fix it? Oh ya my gas flow looks very small and slow flow from tank.
 

Attachments

Mrgreen

New Member
Aug 5, 2020
8
0
1
36
The vent in the tank cap is blocked of not there, you may have to add a very small hole in the center of the cap.
Ya there is no hole in the gas cap. I have same set up on my bike.
 

Attachments

curtisfox

Well-Known Member
Dec 29, 2008
5,138
1,559
113
minesota
Take the cap off and run without see what happens, if it still does it got to be something else..............Curt
 

Mrgreen

New Member
Aug 5, 2020
8
0
1
36
Take the cap off and run without see what happens, if it still does it got to be something else..............Curt
When I remove the cap it flows better, would that still be the filter? I just dont think I can drill threw it, look at the picture. All suggestions help. I removed the tank and carb. I didn't think to check the new tank filter though.
 

Attachments

Mrgreen

New Member
Aug 5, 2020
8
0
1
36
Nice. I'm gonna check the new tanks filter that I put, cause I checked the old tanks filter after I took it off and it was clogged. I'll check the new one, maybe take it off and put on the line filter. If that dont work I need to find a lid with a hole. My kid is too thick. I just dont know where I can get a cap like that? What type of tank cap u have, no troubles?
 

Attachments