wickedsickbike

wickedsickbike

New Member
Jun 16, 2008
15
0
0
connecticut
It's a front suspension mountain bike.With a 80cc motor. I have owned it about 4 weeks and runs excellent.It goes 25mph, at 3/4 throttle without to much vibration.it's completly stock. Having coil/cdi problems in the past week, just doesn't want to start.my new coil is in friday, hope that works.I'm only on third tank.I understand we can upgrade on sprokets,exhaust,carbs,intake,etc....Any suggestions on making this bike smooth,reliable and 35mph ripper.(c)
 

Pablo

Master Bike Builder & Forum Sponsor
Dec 28, 2007
3,664
5
38
Duvall, WA PNW
www.sickbikeparts.com
I understand we can upgrade on sprokets,exhaust,carbs,intake,etc....Any suggestions on making this bike smooth,reliable and 35mph ripper.(c)
35 mph is doable, very doable. First thing is to get it started again :D

Next get a jackshaft to put that sick bike to work for you!! You got gears, USE THEM - available in July.

Then let the engine breath......port and polish and add an expansion chamber kit.
 

wickedsickbike

New Member
Jun 16, 2008
15
0
0
connecticut
just got today a new cdi with plug wire and plug. Even checked the magneto, evrything looks good. Still won't start.purchased the 80cc kit on may.13th,2008.What to do!:confused:
 

wickedsickbike

New Member
Jun 16, 2008
15
0
0
connecticut
Blue wire to blue wire,black wire to black wire. Even kill switch is disconnected. Plug does get wet,but i let it dry, used starting fluid, still nothing.magneto looks good.