Sudden cut out and wont start

Mar 16, 2016
118
0
16
america
This is a stock (except for spark plug) 60cc flyinghorse engine. It's run perfectly for over a year as a daily driver to school and work. I was idling at a stop light today after filling the tank up and it cut out. Just like if i had hit the kill switch. She wont start at all just turns over and turns over and as soon as i stop pedaling stops turning. It's too dark to do anything tonight so I'd like some suggestions o what could be wrong for the morning. Anything will help, thanks!
 
Mar 16, 2016
118
0
16
america
Thanks, I borrowed a neighbor's head lamp so i've trouble shooting. Gas seems to only fill the tube halfway but then stops. Then with the tube not connected it flows freely. This seems to be problem unless it has always done that i've never noticed it. Could this be a jam in the carb maybe?
 

Kartooo

Member
Nov 18, 2016
178
3
18
MA
there is a drain screw on you carb bowl. back it out a few turns and see if fuel runs out with the petcock open.
 
Mar 16, 2016
118
0
16
america
Fuel drips out pretty quick a couple turns out so I guess that means it's getting fuel? I noticed my CDI boot is pretty loose so I'm going to check the spark to see if it's just not connecting properly.
 
Mar 16, 2016
118
0
16
america
Not getting spark. It's odd that it stopped working while i was at idle and not rattling around or something but i think that's definitely the issue. Thanks guys.
 

Kartooo

Member
Nov 18, 2016
178
3
18
MA
these cheap little china mtrs amaze me....
lately every ride i gain more trust in them and drive further.
do you have a guesstimate of how many miles you have on it ?
i searched but could not find a thread on how many miles people have on these mtrs.
are there any documented cross country journeys ?
they are small enough that you could carry a spare mtr in a saddlebag.
i guess if you don't beat on them the bike wears out before the mtr !!
 

crassius

Well-Known Member
Sep 30, 2012
4,032
156
63
USA
most mags read a little more than 300ohm from blue to ground (really old ones are 250, some new ones are 480)
 
Mar 16, 2016
118
0
16
america
Kartooo, I'd geustimate around 2000 miles. This is the first thing that's really gone wrong with it so far, and I keep my bike outside (not by choice) and ride it every day so it gets pretty beat. If you aren't stupid with them and don't try to cruise at 40 they last pretty well IMO. Crassius; thanks ill check.
 

Jesse Marshall

New Member
Jan 31, 2017
4
0
0
New York
Don't overlook the fact he filled up his tank check the plug and always make sure you shake up your gas very well. I had that happen once. Drain the gas if the plug is black from the tank and carburetor replace plug fill gas give it a shot then take it from there.
 

Kartooo

Member
Nov 18, 2016
178
3
18
MA
Kartooo, I'd geustimate around 2000 miles. This is the first thing that's really gone wrong with it so far, and I keep my bike outside (not by choice) and ride it every day so it gets pretty beat. If you aren't stupid with them and don't try to cruise at 40 they last pretty well IMO. Crassius; thanks ill check.
good for you, these little china mtrs amaze me.
maybe the weather took it's toll on the mag.
i silicone my cover and the lead in plug to keep the weather out.
never push mine, there is a sweet spot where everything goes smooth.
around 1/3 throttle is where i keep em at.
hopefully the new mag cures it.
 
Mar 16, 2016
118
0
16
america
Replaced the CDI because the spark plug boot was loose anyways which didn't fix the problem and just replaced the megneto and she runs perfect again. Thanks guys :)
 

Jroge1523

New Member
Aug 28, 2017
18
1
1
34
That happened to me twice both magneto i ride to work everday and back 25 miles 6 days a week so i have had my fair share of problems its the magneto