wants to start but not catching

noodlecare

New Member
Mar 8, 2016
28
0
0
Uk
Hello, I have a 2 stroke flying horse "80" cc motor. I put everything together and it wants to start but cant keep it up and running for more than a few seconds at a time. Also my carburetor keeps leaking gas extensively and constantly. I think this might be do to the fact that i have the engine mounted at an angle where the carburetor is lower than the manifold
 
Last edited:

crassius

Well-Known Member
Sep 30, 2012
4,032
156
63
USA
I'd guess you are over-rich with that leak (like having choke on all the time)

you might be able to lower float level, but I'd really try to get motor remounted

pic would help
 

noodlecare

New Member
Mar 8, 2016
28
0
0
Uk
I'd guess you are over-rich with that leak (like having choke on all the time)

you might be able to lower float level, but I'd really try to get motor remounted

pic would help
Thank you for the reply. I will try that next time.
 

noodlecare

New Member
Mar 8, 2016
28
0
0
Uk
Do you guys think thats the reason it wants to start but cant catch aswell. Also does anyone have a solution for the smell of gas. cause when it leaked it got on my frame........
 

noodlecare

New Member
Mar 8, 2016
28
0
0
Uk
Update:

I re positioned the engine properly and fixed my gas tank location. I have successfully fired my bike up and it sounds nice and loud! Problem is i popped my tire...... :(. So ill get that fixed soon and post updates. I appreciate all the amazing help.
 

lobsterman61

New Member
Aug 6, 2017
5
0
1
59
New 80cc only starts when it wants to. I tried different plugs, and again it only starts when it wants to. Took off the kill wire but made no difference. Anyone having the same problem?