no fuel

Ghost#1

New Member
Oct 8, 2021
2
0
1
50
Im running a husang 4 stroke with less then 200 km on it i parked it for about 10 days when parked was running perfect after would only run with the choke full on check for an air leak it seems like I had one I replaced the gaskets now with the gaskets on it won't run at all I take the gaskets off and it will only run with the choke on the gas will not flow from the gas tank to the carburetor but it flows free if I pull it off the carburetor the carbs been soaking solvent overnight and cleaned and confused about it I have primed it and it will run as long as you know the gas that I threw in once that gas is gone it shuts off again any ideas
 

Greg58

Well-Known Member
May 1, 2011
4,537
1,360
113
63
Newnan,Georgia U.S.A.
Check the gas tank cap, the vent could be stopped up of may not be there at all. Most tanks have a small filter screen on the valve, I would check that as well.
 

Ghost#1

New Member
Oct 8, 2021
2
0
1
50
ill look at the tank but as i stated the furl will fkow if i pull it of the carb i put a clear line on it and it immediately gets air on the tank side ill also clean the carb again its possible i missed some dirt or got some. in reassembling it
 

Venice Motor Bikes

Custom Builder / Dealer/Los Angeles
Mar 20, 2008
6,783
704
113
Los Angeles, CA.
It sounds like there's a bit of debris clogging either the jet or the idle circuit.

I really hate the stock carburetors on these engines!! I always have trouble getting them to run properly after cleaning them.

My solution has always been to install a NT 2-stroke carb... (but it will need a bigger jet).... good luck!