new engine running rough

blockhead

New Member
Sep 20, 2008
6
0
0
I just finished installing my 77cc 2 stroke and it runs really rough + will not idle is this a bad carb to manifold seal? I have changed the plug just to start some where with no changes fuel is 32:1. Please Help
 

Norman

LORD VADER Moderator
Staff member
Jan 16, 2008
2,605
2
38
68
pampa texas
They don't run the best when you first get them going it will take some time to for it to brake in and you can turn in the idle screw to get it to idle.
There's going to be people whine about you using the 32/1 mix starting out but since you've got it mixed use it or add about 1 oz of oil to the gallon mix its best to run them oil rich for the first couple of tanks of fuel then go to what ever kind of mix you like. I don't really see it a problem to go with the 32/1 mix right off the bat myself, I don't baby these engines they are red headed step childern to me so have fun.
Norman
 

Pablo

Master Bike Builder & Forum Sponsor
Dec 28, 2007
3,664
5
38
Duvall, WA PNW
www.sickbikeparts.com
I just finished installing my 77cc 2 stroke and it runs really rough + will not idle is this a bad carb to manifold seal? I have changed the plug just to start some where with no changes fuel is 32:1. Please Help
Norman is right. They run rough new. I suggest replacing the spark plug wire and making sure there are no intake leaks. Also make sure fuel is flowing well.

What is your plug gapped at?

I assume your fuel is freshly mixed with fresh gasoline.

Ride it for a while, get it hot. Then check your spark plug.