My new engine is making weird noises and losing power Help!

Muaya

New Member
Mar 15, 2019
10
1
1
28
Hello, I have a 80cc CDH Power with less than 200 miles. I'm still using the 16:1 mixture, however recently it began losing power specially when going uphill and the other day it completely left me stranded.
I had already cleaned the carb a couple of days before that. Today after changing the spark plug and praying, it started again, however it is still making ugly noises and losing power.

This video's quality is really horrible, but the important thing is the sound of the engine, can anyone please give me any advice?
 

allen standley

Well-Known Member
Oct 22, 2011
1,115
204
63
Bangor, Maine
While engine is cold, check head bolts, Noisy rattley sound could be the clutch gear needs a dab of grease.
Right side cover - remove 5 screws / bolts, If dry- place a small dab of thick grease between small and large gears. NOT a lot, you do not want to get any grease in your clutch pads.
Also... After you expire the 16:1 mix in your tank now, go ahead and reduce oil mix to 32:1. (4oz oil 1 gal gas)
 

Muaya

New Member
Mar 15, 2019
10
1
1
28
Figured I would bump this thread to you . Torque specs and a couple tips/info handy for you now.
https://motorbicycling.com/threads/first-build-got-any-motor-reliability-tips.63611/#post-663328
Thank you very much, and I really apologize for my delayed response. My dad's store was robbed, and after that I forgot about the engine.

It turned out to be the magneto coil, I took the engine to a mechanic and according to him he only calibrated the magneto and now the Bike is running great.
 
  • Like
Reactions: allen standley