ignition system problems

Discussion in 'Motorized Bicycle General Discussion' started by SmokerX, May 20, 2009.

  1. SmokerX

    SmokerX New Member

    Joined:
    Dec 10, 2008
    Messages:
    34
    Likes Received:
    0
    I have a single bolt now holding my bottom mount. Last time I rode it the vibration, caused the
    bottom bolt to fall out and the engine to twist completely out of the frame. When this happened it pulled the plug wire out of the cdi and disconnected the black and blue wires connecteing mag and cdi. I first reconnected the wires and shoved the plug wire back into the cdi. The bike puttered with no power or idle. Then I found a cdi in a box of junk parts(not sure on its condition, but it looks new) I wired the other cdi up and same problem. when the engine twisted it could have pulled the
    other end of the wires attached to the mag loose,but i Haven`t opened the plate to check. Ive experienced these symptoms before when my blue wire was accidentally disconnected from the cdi.

    So i was wondering if there`s any way to determine whether I should order the CDI or check the mag. based on symptoms. It does sound like it runs a little, but no power or idle.
     
  2. Bikeguy Joe

    Bikeguy Joe Godfather of Motorized Bicycles

    Joined:
    Jan 8, 2008
    Messages:
    11,529
    Likes Received:
    2
    I'd check all the connections first, then try a new mag coil/cdi.
     
  3. SmokerX

    SmokerX New Member

    Joined:
    Dec 10, 2008
    Messages:
    34
    Likes Received:
    0
    I got a new cdi and put it in without checking the connections. Still didn`t work. So I checked the voltage with a multimeter on all the wires coming from the Magneto, after struggling to get the magneto plate open (stripped screw), and checking the magneto and wire connections to make sure they looked good. Turns out the black wire was fried because the copper wire pulled apart internally leaving the plastic case intact. I replaced the wire, 18 guage if anyone was wondering. and put new connectors on. the ones connecting the wires are known as bullet connectors. I`m not sure what the loop one that hooks up to a bolt in the magneto is called cuz i dug it out of a spare parts box. So my bike is running now.
     

Share This Page