HUGE backfire issue!

Nnn

Member
Mar 15, 2018
115
4
18
46
My engine will no longer start because it's backfireing so bad it won't stop no matter what I do. Also when I'm at full throttle at low speed it send air and fuel out the air filter side on the carb. When I took the air filter off and out my hand infront of the carb and full throttle I felt air hitting my hand and it was covered in gas after. Have no clue what's up any help is appreciated
 

Nnn

Member
Mar 15, 2018
115
4
18
46
I no
usually, it is air leak or fuel blockage
there is no air leak in the carb and other gaskets throughout the engine but I’m not sure about the crankcase seals. They have given me trouble in the past but they are showing no signs of leaking right now. Is there a way I can seal them off with some sort of glue or gasket sealer to be sure?
 

Nnn

Member
Mar 15, 2018
115
4
18
46
I removed the boost bottle on my bike and put back a intake manifold without a hole and it seems a lot better. Still slight backfires but it's gotten better.
if no air leak, maybe clogged main jet

a bad CDI can do this but it is rare
Tomorrow I will open up the carb and see it's not the CDI because I tried multiple
 

Nnn

Member
Mar 15, 2018
115
4
18
46
I opened up the carb and it was spotless inside and there was no blockages. Still backfires like a mad man and can't full throttle at low speeds without it shooting air and fuel out the filter side of the carb. It seems like there's a fuel leak but I have no clue were I have checked all around the engine and nothing
 

crassius

Well-Known Member
Sep 30, 2012
4,032
155
63
USA
the other backfire thread turned out to be clogged fuel filter making it lean
 

Nnn

Member
Mar 15, 2018
115
4
18
46
I removed the gas line from the carb then put it into a water bottle. I opened the fuel valve and small but steady stream of gas came through the lines and filter.
 

crassius

Well-Known Member
Sep 30, 2012
4,032
155
63
USA
you need to open drain plug on bowl of carb and try that again to check flow thru carb
 

Soraandaxell

New Member
Sep 18, 2018
16
0
1
27
Have a “stock” china girl 66cc slant head with a b5hS spark plug, BBR volt master cdi, and just upgraded to a Thomas (dellorto clone) carb and a 32 tooth rear drive sprocket. I’ll pedal it up to about 10-12 miles an hour and it seems to drop in gear just fine, but will not for the life of me pull me what so ever. Not even as I’m pedaling ...I’m 130lbs and only travel on flat ground on a 26in beach cruiser. I’m wondering if it has anything to do with having to tune the carb first
 

Tyler6357

Well-Known Member
Mar 15, 2012
1,142
170
63
Santa Barbara, CA
I no

there is no air leak in the carb and other gaskets throughout the engine but I’m not sure about the crankcase seals. They have given me trouble in the past but they are showing no signs of leaking right now. Is there a way I can seal them off with some sort of glue or gasket sealer to be sure?
Did you open the mag case plate and see if there is any oil in there? It could be the seals, check the clutch side too.
 

Nnn

Member
Mar 15, 2018
115
4
18
46
you need to open drain plug on bowl of carb and try that again to check flow thru carb
I opened the serial plug on the carb the turn the petcock to on and there was a steady flow of gas coming out of the carbs drain plug. Therefore fuel is getting into the carb.
 

Nnn

Member
Mar 15, 2018
115
4
18
46
Let me give a run down if the point I'm at right now. The carb gets fuel. There are no leaks in the mag seal or clutch seal. The intake gasket or gasket under cylinder wall is not leaking either. The engine burns a lot of fuel, backfires and appears to run lean according to plug color but I have no boost bottle and c clip is at 3rd to bottom setting which is fairly tich. All signs indicate there's a fuel and air leak but I have no clue were. I know it's something simple but can't find it
 

crassius

Well-Known Member
Sep 30, 2012
4,032
155
63
USA
that is a weird collection of parts - how did it run before all the "upgrades"?
 

Nnn

Member
Mar 15, 2018
115
4
18
46
that is a weird collection of parts - how did it run before all the "upgrades"?
It always backfired even when I first got the kit but it was so rare it wasn’t even an issue. The gas mileage always sucked and I never checked the air to fuel ratio until later on. The only difference between before and after the upgrades is that the engine has a lot more power and backfires a **** ton
 

Venice Motor Bikes

Custom Builder / Dealer/Los Angeles
Mar 20, 2008
6,611
419
83
Los Angeles, CA.
Backfiring is almost always from either a carb issue or the timing being off.

Clean out the carb jet first; if that doesn't help?, then try a new CDI (black box).

Also, make sure your gas & oil is properly mixed!!! (too much oil might also cause this problem)