Hi Yall , Newbie From Florida

HOMEYYYGG

New Member
Aug 10, 2008
3
0
0
ST PETE FLA
HI everybody.I am a newbie here, trying to get info to fix a clutch problem on my bike. my bike is a schwinn with a frame mounted honda 4 stroke gxh50. the reason i 'm here is that my clutch wont engage when i pull the handle, any ideas?:rolleyes: . my bike was just recently built, I have maybe put 7 miles (if that) on it since i bought it. everything is brand new. only thing i did different recently was adjust the idle up a little bit.So any help or ideas you can offer im glad to hear it. Thank you.
 

NunyaBidness

Active Member
Jun 29, 2008
1,062
1
38
memphis tn
hey HOMEYYYGG, welcome aboard
there is a ton of info here, and plenty of helpful people too
can you tell what kind of tension the clutch cable has? maybe broken? what's happening when you try to engage the clutch?
we made need a little more info but I'm sure someone can help you out with your problem
good luck and happy motoring
 

HOMEYYYGG

New Member
Aug 10, 2008
3
0
0
ST PETE FLA
hey HOMEYYYGG, welcome aboard
there is a ton of info here, and plenty of helpful people too
can you tell what kind of tension the clutch cable has? maybe broken? what's happening when you try to engage the clutch?
we made need a little more info but I'm sure someone can help you out with your problem
good luck and happy motoring
The clutch tension is good, cable is not broken. when i try to engage the clutch it just doesnt engage. going to try adding some lucas gear oil & stop leak to the gear box, see if that helps. also on my bike to engage clutch you pull the clutch lever back, unlike some where the clutch is engaged all the time, and you pull back to disengage it.
 

HOMEYYYGG

New Member
Aug 10, 2008
3
0
0
ST PETE FLA
also when i go to engage clutch the cable moves, the arm moves , it just doesnt engage. and im really kinda stumped cause everything is new. so it couldnt have been worn out .