Engine not starting

EyeofNeptune

New Member
Nov 26, 2019
1
0
1
20
My engine will not start. I will pedal, release the clutch, and the pistons will fire and keep firing if I am pedaling but if I stop the engine does too. The clutch works fine, and the fuel is flowing. The only questionable thing I can find is when I open the drain valve in the carburetor, fuel always comes out. I don't know if that is supposed to happen or not. Any help would be appreciated. Thank you :)
 

Greg58

Well-Known Member
May 1, 2011
4,533
1,359
113
63
Newnan,Georgia U.S.A.
Welcome to the forum, if you can give a little more information we may be able to help. Is it a new engine or has it ran before? What have you checked? Is it firing the plug? Let us know and someone will jump in to help.
 

James Thomas

New Member
Dec 8, 2019
3
0
1
45
Yea fuel should be in the bowl .. ya prob is one of three ... Bad cdi ... Bad magneto ... Or bad plug.. start with the plug it's the cheapest and make sure it's gapped no less than 28 but 32 max then go from there!
 

James Thomas

New Member
Dec 8, 2019
3
0
1
45
If it's been in water then it's more than likely ya magneto and also get ya some clear silicone and seal the outside of ya mag case those paper gaskets are no barrier and or get one of the rubber gaskets they make for that very reason .Good luck!
 

waynesdata

Active Member
Jul 10, 2017
254
109
43
43
We badly need a will not start check list. This gets "solved" over and over again.
 

waynesdata

Active Member
Jul 10, 2017
254
109
43
43
Last edited: