Drive shaft spins but drive sprocket doesnt

DirtyBomb

New Member
Mar 7, 2019
14
7
3
40
Hi, Im totally new to motorized bicycles, I have a 4 stroke Huasheng that is having issues with the drive sprocket, it has one of those belt driven transmissions (I guess they are called either 4g or 7g) Im not sure which one it is (bought bike second hand) like I said, brand new to this I dont even know what 4G and 7G even means in terms of a transmission. The problem Im having is that when I give it throttle, the drive shaft starts spinning but the sprocket doesnt. Without tearing it off I looked for a sheared key of some type or an obvious sign of something missing but could not find one.If I take a socket and tighten the bolt down as much as possible Ive been able to ride it but after a few miles at best it begins to do it again and spin the drive shaft without turning the sprocket. Is there some key or pin or something I lost but being such a novice didn’t realize it or is it something else and is there a way I can fix this? Thank you very much for any help
 

DirtyBomb

New Member
Mar 7, 2019
14
7
3
40
5AD361FB-9F5D-44D8-83AC-D4B048FBD3E0.png
81B8DE95-89F0-43C3-BC7D-49C3DBD5D2A8.png
990DC991-8A69-4ED1-905C-15EC8FBC3C17.png
This is the transmission I have, its late at night so I just found the exact same transmission on ebay to show photos of what transmission it is
 

Venice Motor Bikes

Custom Builder / Dealer/Los Angeles
Mar 20, 2008
6,821
742
113
Los Angeles, CA.
When you say "the drive shaft starts spinning" but the sprocket doesn't; What shaft are you talking about??? The shaft with the sprocket, or the engine crankshaft???

Either way, it sounds like you're missing a woodruff key somewhere.
 

DirtyBomb

New Member
Mar 7, 2019
14
7
3
40
When you say "the drive shaft starts spinning" but the sprocket doesn't; What shaft are you talking about??? The shaft with the sprocket, or the engine crankshaft???

Either way, it sounds like you're missing a woodruff key somewhere.
The shaft with the sprocket. The sprocket and chain sit there doing nothing while the shaft spins. If I tighten that nut on the end it works for a while then starts doing the same thing