clutch dose nothing

darkthorn_pro

New Member
Aug 3, 2008
10
0
0
My clutch dose nothing I mean nothing none of the internal parts move none
It will no disengage for any thing
 

Dave31

Moderator
Staff member
Mar 1, 2008
11,204
29
38
Aztlán, Arizona
On your last post you said you have alot of play in your clutch arm...is your clutch arm pointed towards the rear tire?

If it is...be sure your pin and ball are in the center of the drive sprocket. I know one guy who got a kit from Revolution cycles and it was missing.
 

cdoug50

New Member
Jun 25, 2008
24
0
0
Maine
I had same problem when I first received my engine. Luckily, I tried to disengage the clutch before mounting the engine. Could not for the life of me get it to move until I called the seller and he explained that sometimes when these engines set on the shelf for awhile, the clutch will freeze and it's just a mattter of putting enuff pressure on the clutch arm to get to move. I laid the engine on it's side and put just about all my weight on the clutch arm and it worked. Was still stiff for a couple days after that but now works freely.
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
236
63
up north now
What moves and what doesn't move? Can you push the arm? If you can, you are saying it doesn't push the rod and ball? You can't see the plate move with the cover off?
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
236
63
up north now
You got the cable tight enough? If not, you can pull the lever and all that will happen is the cable, lever and arm will move and nothing else.
 

darkthorn_pro

New Member
Aug 3, 2008
10
0
0
Yes but as i said nothing moves it has nothing to do with that side of the motor the rod wont push in no amount of adjustmen on the other side of the moto witll help that belive me ive tried
 

misteright1_99

New Member
Mar 21, 2008
716
0
0
Treasure Coast, Florida
Yes but as i said nothing moves it has nothing to do with that side of the motor the rod wont push in no amount of adjustmen on the other side of the moto witll help that belive me ive tried
The two side are in direct contact by the rod and ball. The clutch arm pushes the rod and ball to push the clutch plate out on the othe side. If the clutch plate is tightened too much the arm, rod, and ball will not move. You could also try some grease in the hole under the carb that the clutch cable housing mounts to. Inside that hole is the clutch spring.
 

darkthorn_pro

New Member
Aug 3, 2008
10
0
0
Ok the clutch arm moves the rod and ball dont at all Ive removed the outer plate from the other side and still the rod dosent move
do you understand now?:(
 
Sep 13, 2008
16
0
0
I have a similar problem, my clutch arm moves, but i never get the engine side sprocket to move freely. i can force the sprocket to move, but it turns the engine. I cannot get the clutch to put the engine sprocket into neutral.
any advice?
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
236
63
up north now
If the clutch arm moves, and the rod and ball don't you-
A.) Have something broken since it is a physical impossibility for the arm to move without pushing the rod/ball/clutch assembly.
Or-
B.) The cover is loose and when you push the arm, the case cover moves out and the action of the arm is wasted with outward motion of the cover.

Anything else short of bending the arm to get arm movement is impossible.
 
Sep 13, 2008
16
0
0
Thanks guys, I will be trying this soon.
Bike guy Joe said to do this to the flower nut.
"Remove the small screw that holds it in place. Then, pull in the lever and lock it."
If I find the answer I will post this one up; If I am still stuck I will come back to the board and dig for more answers. Ill even try to take some pics.
Thanks in advance,
 
Sep 13, 2008
16
0
0
OK, I took off the flower nut and removed the clutch plate.
(Thanks for the assembly pic Pablo, it helps me use the correct names!!)
I put the clutch arm back on with the left plate, the clutch arm now can move the drive shaft, and i can see movement on the other side. problem is, I still can not more the Drive Sprocket. I am trying to get the clutch to work to the point where i can spin the Drive Sprocket. Any advice or links to a forum thread that talks about this? I am still reading through Norman's clutch post, but I am not making progress yet