Piston installed backward from factory?

Discussion in 'Instructions for Building and Repairing Motorized ' started by Dryheatbob, Jan 22, 2020.

  1. Dryheatbob

    Dryheatbob New Member

    Joined:
    Dec 28, 2019
    Messages:
    11
    Likes Received:
    15
    Hey all- just started going through my engine(Zeda firestorm 80). Took the head off to make sure the piston moved freely(it does) and it looks like the piston is backward. The arrow is facing the intake port and as near as I can remember the arrow is supposed to face the exhaust port, isn't it? Thanks for the help-
     
    indian22 likes this.
  2. Venice Motor Bikes

    Venice Motor Bikes Custom Builder / Dealer/Los Angeles

    Joined:
    Mar 20, 2008
    Messages:
    6,550
    Likes Received:
    330
    The arrow is different from different factories... It probably installed correctly, SO DON'T MESS WITH IT!!

    & since you took the head off the engine, torque the head down to 12 ft/lbs... anything more will bend the head & cause low compression.
     
    indian22 and Greg58 like this.
  3. Dryheatbob

    Dryheatbob New Member

    Joined:
    Dec 28, 2019
    Messages:
    11
    Likes Received:
    15
    Lol- thanks. Torquing the head down was on my list of things to go through before firing it up. Appreciate the response!
     
    indian22 likes this.
  4. bairdco

    bairdco a guy who makes cool bikes

    Joined:
    Aug 18, 2009
    Messages:
    6,541
    Likes Received:
    220
    To be 100% sure, look into the ports. If you see the ring keeper pin, it's in backwards.
     
    LR Jerry, indian22 and Greg58 like this.
  5. Dryheatbob

    Dryheatbob New Member

    Joined:
    Dec 28, 2019
    Messages:
    11
    Likes Received:
    15
    Pins aren't visible. Sounds like I'm good to go. Thanks.
     
    indian22 likes this.

Share This Page