Motorized bike Unable to idle properly

Tom74

New Member
Mar 23, 2020
16
1
3
France
When I start my bike it will idle very high and then rapidly go down to a normal idle speed. After about 1 minute it will start to decrease in idle speed and produces lots of smoke, it will continue to decrease until the engine has fully died. At first, I thought that I must be the idle screw adjustment that needs adjusting correctly so I proceeded and maxed it out. I started again but it the idle screw adjustment didn't have any effect. I tried many other things like cleaning the spark plug, cleaning the piston and cylinder walls, cleaning the carburettor, draining and replacing the fuel, adjusting the "C" clip, replacing the fuel filter, replacing the fuel petcock and finally checking the spark which was fine. I have done everything at this point that I can think of, I don't think it's an air leak because I tightened the carburettor on really well. One thing that I did notice was that the spark plug was very sooty and black.

My fuel ratio : 40:1
My 2 stroke kit : Chinese
 

Tom74

New Member
Mar 23, 2020
16
1
3
France
Update : I took off the exhaust pipe and it was dripping lots of oil and when I took the cap off it was full of oil so I must be running very rich and when I have the choke ON the engine will not start.
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
235
63
up north now
Check to see if your float is sticking, full of fuel, or a chunk of crud is holding the float off the seat. It happens a lot.
 

Tom74

New Member
Mar 23, 2020
16
1
3
France
I have found the issue, it was the primer button so I took it off and filled the hole with glue from a glue gun. Now it runs perfectly and much more powerful.
 
  • Like
Reactions: FOG