lost top speed

4wdingman

New Member
Aug 26, 2008
69
0
0
Coffs Harbour, Australia
Hi
I have lost top speed ever since I have got a new carby. It very strong and takes off great but it seems like it doesn't hit top speed. Once it hits top speed it feels like the clutch is on. The clutch is not covering the air hole and the trottle does not cover it too.
So can you thing of a reason why it has lost top speed???
 

BlueCollarBike

New Member
Aug 14, 2008
51
0
0
Hi
I have lost top speed ever since I have got a new carby. It very strong and takes off great but it seems like it doesn't hit top speed. Once it hits top speed it feels like the clutch is on. The clutch is not covering the air hole and the trottle does not cover it too.
So can you thing of a reason why it has lost top speed???
Check to see if the screen in the Tank petcock valve is dirty.


cheers:)

Bob
 

tyrslider

New Member
Sep 26, 2008
958
0
0
RainCity
If your float level is too low it could cause this. When you stop your using less gas so you would have enough to start out good, but you could be,in affect running out of gas at higher rpms.
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
236
63
up north now
Check your plug first....see what color it is. Shouldn't be white or light grey. Should be tan to chocolate brown or a slightly oily black. If you are running too lean it will seem weak and get hot quick, too rich and it will have a good pull, but when you hit cruise or WOT it could "4 cycle".

Now, what do you mean "The clutch is not covering the air hole and the throttle does not cover it too."?
 

velardejose

New Member
Sep 9, 2008
120
0
0
Lima, Peru
Hi
My mb has great start too (clean sounding engine)
But when sustaining mid rpms kind of 4cycles
And when flooring it pulls slow
Mb has a 'vibration' speed limiter...
Plug is dark brown
Should I lean the mixture?
Thanks in advance
 

Saddletramp1200

Custom MB Buiilder
May 7, 2008
1,439
40
48
Houston, Texas
Jose, Check your carb for torque against the manifold. They come loose and make an air leak sometimes. No we need more info like mix ratio, plug type, ect.
 

velardejose

New Member
Sep 9, 2008
120
0
0
Lima, Peru
Hi
I sealed the carb-intake tube joint with grey silicon
Mix is 30:1
Plug is ngk b6hs
Needle clip is in the second notch from top
Tire press is 40 psi (jk)
Thanks in advance