Loss of engine power and muffler cap missing

fume555

New Member
Aug 24, 2008
19
0
0
Dallas,TX
Hey guys. I noticed that my bike has recently lost a significant amount of power in the last 3 days. I can only reach up to 23mph top speed and before I could get it up to around 33. Also I lost the cap to my muffler which makes it extremely loud and after about 20 mins of riding, parts of the muffler turn red hot and when I rev the engine high the muffler blows flames sometimes. My mpg is also low, like 40 miles per gallon to the gallon.. 20 miles per tank.. what the **** is wrong?
 

tylerlough

New Member
May 28, 2008
109
0
0
Mishawaka, IN
Is the choke on? Leaving it on will kill gas millage, and it won't reach top speed.
What's the color of the spark plug?
Do you have the muffler with a catalytic converter?
 

Dave31

Moderator
Staff member
Mar 1, 2008
11,204
28
38
Aztlán, Arizona
Without your muffler cap your motor is most likely running too lean!!

Red Hot...Flames :eek:

Fix your muffler or richen your carb adjustment with the e-clip or your are going to toast your motor if you have not already
 
Last edited:

Dave31

Moderator
Staff member
Mar 1, 2008
11,204
28
38
Aztlán, Arizona
weird.

i pull the baffle out of all my personal bikes' exhausts, and each time have gained a very noticeable increase in power.

never heard of anyone losing power.

weird.

First I drilled my baffle, loss power...rich and leaned it out trying to get it to run better, no dice.

I also cut my baffle out and had the same problem...lost top speed and power. So I welded everything back up and it is now all back to stock and runs just fine.
 

fume555

New Member
Aug 24, 2008
19
0
0
Dallas,TX
tylerlough: the choke is only on when I warm up the engine and when it's warm I choke it off all the way. I just recently cleaned my sparkplug because it was fouled with black carbon build up. I'll check my plug 2morrow.
I dont believe I have a muffler with a catalytic converter.. not sure what it is but I dont believe I have it.

fairracing31: yeah, litteraly my muffler blows out a flame when I rev it high and the middle and bottom part of the muffler is red hot coal after a while of running. I REALLY would like to improvise the missing tip.. maybe I could take my muffler to a shop and see if they have the same size for a cheap price and hopefully I could just buy the cap seperately. The muffler on kingsmotorbikes.com is $25 and i'm going to order 2 chain tensioners and MAYBE a new muffler...

spunout:Before I lost power in my engine, I was about to go about 33mph top speed with my muffler cap gone (baffle I think is what its called?). Then after a while I lost my engine power and whenever I full throttle it for 3-5 seconds, the rev sounds like it's about to explode; it sounds like it's not supposed to do that.

Also I'm getting EXTREMELY low mpg.. 50mpg if I cruise at a 17mph.