Is it the magnet?

classclown

New Member
Jun 4, 2021
3
0
1
41
hey guys. I m new to the forum and pretty new to modified bikes and small engines. I have had my china bike about a year. I have had alot of issues, and it has been awesome to have been able to square them all away on my own. Since spring began it has ran great and i have been cruising around at 35mph. So a few days abo it just cut out at high speed. I first noticed the kill switch had fallen out and was gone. the spark plug boot and cdi were a bit loose. unable to start it up, i opened the case to see the ground wire connection on the magneto coil was broken along with a tiny bit of damage on edges of coil. resoldered it and got no joy. I ordered a new coil, cdi, and plug. coil and plug test good. cdi tested good from blue wire to plug. still no start. upon trying, i did notice the magnet does not visably move when i walk the bike with the clutch squeezed. i had already gapped the coil with a playing card. Did I break the crankshaft? Is the magnet supposed to turn with the engine chain? Any help is greatly appreciated. thanks
 

classclown

New Member
Jun 4, 2021
3
0
1
41
my question is really just: is the magnet supposed to spin with the chain and what is the likely culprit if it does not. havent been able to find and answer on this forum or the net in general...
 

Greg58

Well-Known Member
May 1, 2011
4,326
1,233
113
63
Newnan,Georgia U.S.A.
Cutting out at high speed could mean engine damage, did you hear metal to metal sounds? If you have access a compression gauge check the compression, it should be 80 psi or more.
 
  • Like
Reactions: wrench

classclown

New Member
Jun 4, 2021
3
0
1
41
Thanks guys. As it turned out, when I took the cover off the crank case, the entire corner came off with the top right bolt (the one that ppl put a chain guard on). I swapped out the engine and will get a better look at that one soon as i can. The break is clean... Should i strip it for parts, or jb weld it back together?
I appreciate the replies. thanks again.