hello

darkthorn_pro

New Member
Aug 3, 2008
10
0
0
My name i jason I puchased an 80cc chain drive bike kit
I have it on a single speed beach crusier style bike

I have a problem though my clutch wont disengage no matter what i try I have it in properly I know that much but it just wont disengage any one else have this problem please let me know
 

Dave31

Active Member
Mar 1, 2008
11,204
29
38
Aztlán, Arizona
Welcome tot he forum Jason, Glad you joined us :)

Have you tried to adjust it?


A) Disengage clutch by pulling handle bar clutch lever inward and lock into catch lock.

B) Remove right side engine clutch cover and remove small locking screw on center *Clutch Adjust Nut.

C) Pull clutch arm on left rear engine inward. Back off *Clutch Adjust Nut ¼ turn counterclockwise.

D) Release clutch lever and check for slight clutch arm 1/16” free-play on opposite side of engine. Readjust *Clutch Adjust Nut as required to get required 1/6” clutch arm free play.

E) Tighten *Clutch Adjust Nut on clutch plate clockwise until just snug.

F) Then re-install small locking screw in outer edge of *Clutch Adjust Nut.

G) Good idea to place a small gob of grease at gear mesh area. Use grease sparingly! Then replace cover.

H) Squirt light grade oil down clutch cable sheathing to reduce friction and make for easy lever pull.
:ride2:
 

darkthorn_pro

New Member
Aug 3, 2008
10
0
0
I have tried alot of diffent things there is pleanty of free play in the clutch arm and Ive tried adjusting the flower nut all the way fro to tight to way too loose when i squeeze the clutch nothing moves oo the in side Ive looked removed the friction plate and examined it nothing back there moves when i squeeze the clutch it supposed to right?