engine not starting brand-NEW

Jan 4, 2020
6
3
3
21
For some reason my engine won't start I purchased a 80cc 2 stroke kit from eBay came with all the necassary parts I pulled the choke up I have checked the spark plug magneto and throttle tried starting without kill switch cables attached and with it on there is defiantly fuel flowing through the fuel line there's fuel in the carborater bowl I even purchased another carborater and that didn't work the clutch works fine I have tried the same thing with 2 different engines from the same supplier and its the same result I even tried drill starting it visa vi the magneto I twist the spark plug off and I see a misty vapor as i look down into the hole, I've twisted the engine top off and its not wet I just don't know what the problem is its driving me crazy please help I can take photos if need be
 

indian22

Well-Known Member
Dec 31, 2014
4,217
6,003
113
Oklahoma
Do you have a strong spark at the plug? Do you have compression? Is the plug wet with fuel after an extended session of trying to start the motor? If the answer to these three questions is yes. Does the motor attempt to fire?

Rick C.
 
  • Like
Reactions: Greg58
Jan 4, 2020
6
3
3
21
The spark plug yes is quite effective tested it yes there is certainty compression around the ngine chamber near spark plug the spark is not wet after an extended use of time the chamber pumps up and down whenever i attempt to ride when I stop the bike it stops too
 
  • Like
Reactions: indian22

indian22

Well-Known Member
Dec 31, 2014
4,217
6,003
113
Oklahoma
It sounds as though you're not getting fuel to the combustion chamber.. The spark plug should be wet after a lengthy effort to start the engine. Are you priming the carb enough before trying to start the motor (five or six pumps on the carb prime button)? And then choking the carb while trying to pedal start? If you have sufficient compression, spark and fuel the engine should at least try to start and run.

Rick C.
 
Last edited:
  • Like
Reactions: Greg58

Venice Motor Bikes

Custom Builder / Dealer/Los Angeles
Mar 20, 2008
6,827
765
113
Los Angeles, CA.
The engine will not start with the choke lever all the way up!!!
The best position for the choke lever to work is about 1/2 way up.

In most cases, you don't even need to raise the choke lever to start it
 
  • Like
Reactions: indian22
Jan 4, 2020
6
3
3
21
So I tried starting with the choke lever down it worked all was great I started it a few times then I leave it till the morning try again and its not starting at all it attempts to fire put its the same problem as before while i was trying to start i even move the choke lever up and down its still messed up I check the smark plug and thats fine so what is it
 
  • Like
Reactions: indian22

Greg58

Well-Known Member
May 1, 2011
4,628
1,408
113
63
Newnan,Georgia U.S.A.
This is where trial and error comes into play, every engine combo is different and what mine needs to start may be slightly different than yours. Try several till one choke position works. Always turn the fuel off at the tank when you stop, the stock carb is bad about flooding the engine.
 
  • Like
Reactions: indian22