Dumpster find won't run. Ideas?

Zsm0115

New Member
Feb 22, 2017
7
0
0
Wichita, KS
Hello all. I pulled a 80cc 26" mountain bike out of my apartments dumpster. i have no idea what happened to it but i tried to get it running. I got new spark plug, drained tank, new fuel mix, new fuel filter and line, checked all the wiring and nothing. so i tore down the whole kit and everything looks fine. re-assembled the whole thing and got 2 or 3 pops out of it (after riding around for 15 minutes) and nothing since. cylinder moves freely, has compression, getting fuel, spark is very weak ( light purple to white). i tested the CDI and got really weird ranges. i cant test Magneto since i have a the 2 wire model ( black wire is soldered to coil and to frame). i don't want to dump a bunch into it. any help will be great. :-||
 

Zsm0115

New Member
Feb 22, 2017
7
0
0
Wichita, KS
Ok tested Magneto coil and get no reads anywhere so i'll guess its dead. also got wrong spark plug so if i can get any extra money i'll try and fix them two issues. then get new CDI after if it still wont start. wish i could get it going since my job is only 2 miles away and my gas hog of a truck is only getting 8mpg. thanks all
 
Last edited:

Chaz

Well-Known Member
Jun 3, 2012
1,004
70
48
Vancouver, British Columbia
Try the correct spark plug first. You can gap the plug down to 022 and see it that helps. Also, you can try starting without the muffler as they can get sort of clogged up. The muffler can be cleaned an re-used.
 

Zsm0115

New Member
Feb 22, 2017
7
0
0
Wichita, KS
I pull magneto coil off to test it and now i have no spark. engine isn't flooding from what i tell. spark plug is soaked in gas sometimes. how do you go about cleaning muffler? i took the bolt of it to drain it ( had a ton of water/gas in it). also is there a way to find out what motor (brand) i might have? its all painted black with red specks in paint. ( all but intake tube which is still chrome offset tube). so i dont think it was black to begin with. i think im also running to high of mix, probally (40:1, mix one bottle of 2 stroke oil. 6.5 oz with 1 gal of 87 gas) I'm thinking of getting a new CDI and Magneto coil and magnet from gasbike.com since its only $25 total. my wife shops on wish and they have coil and CDI for $13. anyone buy parts from either? Thanks all for the help
 
Last edited:

Chaz

Well-Known Member
Jun 3, 2012
1,004
70
48
Vancouver, British Columbia
You can clean the muffler with carb cleaner. Spray some in and roll it around, let it soak and then blast with pressure washer or strong hose.

You had spark so check all your electric connections to ensure that they are solid and clean. May be difficult to see spark in broad daylight.

It's possible to install the magneto backwards. If so you should still get spark but at the wrong timing.

Try the above and previous advice before you start buying new parts.
 
Jan 21, 2015
610
21
18
Portland, Oregon
If spark plug is soaked in gas, the engine is probably flooded. Also don't buy from gasbike. Most everyone I've talked to (including myself) hates them. Also take a bunch of pictures of the bike and post them, they will help us figure out whats wrong with it.
 

Zsm0115

New Member
Feb 22, 2017
7
0
0
Wichita, KS
ok something funny. i drained the tank again and noticed the petcock has never been opened fully. its one that has 180 degree value so inline toward carb is closed and inline to tank is open which is weird since i was getting gas in closed position. Is 40:1 to rich that it wouldn't of fired? i would take pictures but my phone is bricked and i don't have another camera. on magneto coil i have single copper wires from each side of coil just lose. any ideas where they should go?
 

Zsm0115

New Member
Feb 22, 2017
7
0
0
Wichita, KS
Well some bad news. I had the bike on my patio for the last month and last night someone decided them needed more than me. filed police report and hope for the best ( but we all know how it goes with stolen bikes). to bad for whom ever took it it's going to have a hard time getting it running ( no piston rings, no cdi, no plug, and no magneto magnet or coil). thanks for all the help when i had it.

:-||