Runs great at 20mph but

Discussion in 'Motorized Bicycle General Discussion' started by philymitch, Mar 24, 2009.

  1. philymitch

    philymitch New Member

    Joined:
    Feb 7, 2009
    Messages:
    94
    Likes Received:
    0
    My bike runs good at 20mph and starts within 10 feet. All is good till you hit 23mph then the motor acts like it wants to die like starving for air or out of gas. I put a new spark plug and wire in, cleaned the carb. cleaned the air filter, and put all new gaskets on the intake, carb, and exhaust and the problem is still there it wont go away. If you have any ideas please let me know.
    :-||
     
  2. Bikeguy Joe

    Bikeguy Joe Godfather of Motorized Bicycles

    Joined:
    Jan 8, 2008
    Messages:
    11,529
    Likes Received:
    1
    Does it have a steady staccatto sound or does it cut out and then run O.K.?

    The first one is too rich...move the needle clip up a notch. The second condition is from fuel starvation, and that can be caused by any number of things, including inadequate fuel flow, a float that is set too low or a gas cap that is not venting properly.
     
  3. freewheeling frank

    freewheeling frank New Member

    Joined:
    Mar 10, 2009
    Messages:
    440
    Likes Received:
    0
    see my post:engine not 1oo percent. i stuck a oring between the carb and manifold and now the thing does not leak any air at all, i was having the same problew but i think this will fix it. read the post as there is more info there. frank
     
  4. philymitch

    philymitch New Member

    Joined:
    Feb 7, 2009
    Messages:
    94
    Likes Received:
    0
    Thanks frank and Joe I have an o ring on the carb already. Mb monkey was helping me on the chat box and it was a fuel problem... my bike was to lean and the fuel filters were clogged.
    runs a lot better know. Thanks for your help guys.
     
    #4 philymitch, Mar 24, 2009
    Last edited: Mar 24, 2009
  5. philymitch

    philymitch New Member

    Joined:
    Feb 7, 2009
    Messages:
    94
    Likes Received:
    0
    How do you set the float..... all my motor has is a u shaped brass piece held with a pin that has no adjustment. do you have to bend the u shaped brass thing.
     
  6. DEATH4OF4

    DEATH4OF4 New Member

    Joined:
    Mar 22, 2009
    Messages:
    108
    Likes Received:
    0
    I Had A Problem Like That, But Found My Carb Needed To Be Tweeked.then It Ran Fine. A Couple Of Times That Happened To Me Before That, But Stupid Me... I Had The Choke On...
     
  7. theonlyhek

    theonlyhek New Member

    Joined:
    Jul 20, 2008
    Messages:
    53
    Likes Received:
    0
    I was wondering the same thing..., I cannot seem to find any pictures of the adjustment, before and after. I don't understand, and usually I do?!
     
  8. philymitch

    philymitch New Member

    Joined:
    Feb 7, 2009
    Messages:
    94
    Likes Received:
    0

Share This Page