Preplexing Engine Issue

Discussion in 'Motorized Bicycle General Discussion' started by motorizedmatt, Jan 11, 2011.

  1. motorizedmatt

    motorizedmatt New Member

    Joined:
    Aug 31, 2010
    Messages:
    37
    Likes Received:
    0
    Hello All,

    For some reason I cannot determine my bike all of the sudden doesn't run well, it still runs and I still ride it except it will only go about 23mph tops now and it is missing. Whereas I used to cruise at 32mph all day.

    It still pulls well right up until 20 or so but it just runs out of steam and kind of jerks/isn't running smoothly.

    Could this be a magnito issue? For some reason I am on my 3rd magnito on this engine (has about 1800 miles on it). All the wiring is good and there is a good seat on the plug.

    Anyone shed some insight on this for me?

    And does anyone know where I can get an engine kit in CA? I got 2 from a buddy on craigslist but he can't get them anymore and I desperately need some parts.

    cvlt1
     
  2. 2door

    2door Moderator
    Staff Member

    Joined:
    Sep 15, 2008
    Messages:
    16,304
    Likes Received:
    29
    Try this for an engine kit in CA. Custom Motorized Bicycles / Bicycle Engine Kits / Los Angeles| VeniceMotorBikes.com

    As for your problem there could be several things causing it. 2 cycle fuel, once mixed has a relatively short 'shelf life' A few weeks and it begins to go bad. How old is your fuel?
    Have to looked at your spark plug? What color is the tip (electrodes and porcelain) It might be fouled. You'll want a nice dark chocolate color. If it's black and oily clean or replace it.
    What fuel mix ratio are you using. With the milage you've reported it is well broken in so you should be doing something in the 32:1 range.
    What has happened to the previous magnetos? Did they just quit or get wet? Is there any sign of oily residue inside the magneto cover?
    There's several things to think about. Get back to us with what you find or have done to check this loss of power you're experiencing.
    Tom
     
  3. motorizedmatt

    motorizedmatt New Member

    Joined:
    Aug 31, 2010
    Messages:
    37
    Likes Received:
    0
    Thanks for responding Tom. The fuel is only about a week old, never any older than that.

    I checked the spark plug out a couple of days ago and it was black but to me it didn't look that bad.

    Im using 32:1 mixture. The old magnitos just died when I was riding somewhere. Tried to start em back up and it just wouldn't go, never got wet or anything I don't ride it though puddles or the rain. Last time I took the magnito out there was a really small amount of oil in the bottom of the case but the magnito wasn't wet at all. (probably just from my leaking gas tank that Piston Bikes sent me)
     
  4. 2door

    2door Moderator
    Staff Member

    Joined:
    Sep 15, 2008
    Messages:
    16,304
    Likes Received:
    29
    Matt,
    Oil in the magneto cover could be a result of a crankshaft seal going bad. This can cause some running issues as it allows air to enter and make for a lean running condition. It can also compromise the magneto if the oil is sufficient to shunt across the leads.

    It sounds like you have a good handle on troubleshooting so I can only armchair guess at the problem. If the plug is dark but not wet then that indicates a slight rich condition but with so many miles on your engine I hesitate to say that is the issue here.
    How does it idle? If the idle speed is elevated then that too can represent an air leak.

    I doubt seriously that we're looking at a worn out engine. There have been many that have accrued lots more miles than what you have without trouble.
    Is there any signs of oil/gas around the head gasket or cylinder to case gasket?

    How about a partially plugged exhaust. The muffler, especially the catalytic converter style, have been known to get plugged/fouled with oil and exhaust residue. A partially plugged exhaust is another thing that can cause a decrease in performance. I hope we can solve this issue for you soon. Maybe a few more guys will chime in with their opinions too. Guys???
    Tom
     
  5. Bob Mac 18704

    Bob Mac 18704 New Member

    Joined:
    Jan 24, 2010
    Messages:
    127
    Likes Received:
    0
    I second the muffler theory.It even states in the install instructions that the muffler is short lived, because of the oil. Another plus for the use of opti-2. Much less oil going into the exhaust to plug the muffler. The newer mufflers come apart or can be cut apart cleaned out and then rewelded. Good luckscratg
     
  6. solokumba

    solokumba New Member

    Joined:
    Nov 24, 2010
    Messages:
    215
    Likes Received:
    0
    Sounds like muffler gunk to me too.
     
  7. Sideshowbob

    Sideshowbob New Member

    Joined:
    Dec 26, 2010
    Messages:
    64
    Likes Received:
    0
    I also like the muffler and air leak in crankcase issues. Vespas are notorious for case half leaks and these china motors are the 2 half type as well. The way to check for crankcase leaks is to squirt something volitile like starter fluid or brake parts cleaner anywhere it may leak. While At idle if the idle increases as you spray around you found the leak. Behind the magneto could be tough to get to. Locktite gasket eliminator(grape jelly) works great to seal case halves.
     

Share This Page