flower nut problem need help

joetrammel

New Member
May 30, 2016
31
0
0
Fremont, Ca
So the flower nut does not move but the shaft that it threads onto moves and end up loosening it and my clutch wont engage has anyone into this problem before?r.ly.
 

crassius

Well-Known Member
Sep 30, 2012
4,032
156
63
USA
never, the pin that keeps it from turning at the spring is very strong - are you sure it isn't just stripped
 

ZipTie

Active Member
Jan 8, 2016
750
48
28
Mpls Mn
Just to be sure make sure your clutch handle is pulled in and locked in order to get the flower nut to turn easy , and lock screw removed. you probably know this but just making sure. Then I guess put a drop of WD 40 on the flower nut threads if corrosion exists?
If this as been done something is wrong. Give it some love taps if all else fails. Works on occasion. I've never had one stuck, normally very loose once the clutch is pulled in. I've worked on at least 10 different engines, and Crassus probably in the hundreds. Let us know what you figure out.
Ps. That Chinese factory grease can be more like glue when old.
 

crassius

Well-Known Member
Sep 30, 2012
4,032
156
63
USA
there is a pic I uploaded in another thread that I can't seem to re-up in this thread showing the large pin that holds that threaded shaft

I doubt it could fail. but maybe so - did you check that woodruff keys are in and it isn't just the whole shaft that is turning?

board says; "clutch grubee gt.jpg:
You have already attached this file in thread : Hello everyone Pleas help me solve my clutch problem!"