2 stroke clutch not engaging

scribbles

New Member
Jul 4, 2008
29
0
0
Well i finished my 50cc happy time build... i got 40 miles on the motor and now i am having clutch problems. When i try to engage the engine it acts like im still slightly puling the clutch and wont turn the engine over.. but when i push the arm out with my finger and pedal it starts but not a lot of power... i believe there is something wrong with my clutch adjustments... i have tried readjusting it but no luck... any advise or tricks or solutions to my problem would be super sweet....
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
235
63
up north now
Take out the screw, turn the flower nut in one turn, try it.

Better yet, clean the pads with some spray brake cleaner. Works like magic.
 

Bikeguy Joe

Godfather of Motorized Bicycles
Jan 8, 2008
11,843
235
63
up north now
Remove the small screw that holds it in place. Then, pull in the lever and lock it.

If your clutch is dragging, that's a waste of time. You will want to remove the cable end, adjust the cable adjustment at the lever and the engine to the middle of their respective adjustments, then have a helper push the arm until good resistance is felt. Re-install the cable end.

That will usually do it.
 

FileStyle

New Member
May 27, 2008
724
1
0
Decatur,IL
Take out the screw, turn the flower nut in one turn, try it.

Better yet, clean the pads with some spray brake cleaner. Works like magic.
By spraying with brake cleaner does this help get rid of unwanted oil's on the flywheel and or pressure plate? what about the pads themselves, do you think that they could be roughed up a little so they bite more? Iam having a problem with starting! The motor does'nt want to turn right over, it feels like it wants to grab as it is hard to pedal! but still does'nt start right away. does this more than likely be the reason , that my pressre plate or pads are dirty? it takes me out the drive and down the road before starting! my other MB fires right up before you get out of the drive. Ive checked the pads and it seems that on the plate side there may have been grease. so, brake cleaner huh!?

scratg