Motorized Bicycle Engine Kit Forum  


Go Back   Motorized Bicycle Engine Kit Forum > Motorized Bicycle Welcome Forum > Introduce Yourself

Introduce Yourself Meet & greet your fellow motorized bicyclists, make introductions and even find others in your area.

Thread Tools Display Modes
Old 01-01-2011, 03:12 PM
longtime longtime is offline
Motorized Bicycle Newbie
Join Date: Jan 2011
Location: barbados
Posts: 1
Default engine not working

This is my first time here,happy new year to one and all.could some one tell me what is wrong with this engine.This a 80cc 2 stroke bicycle gas engine I buy and it did work at first but I had to leave the island for business for four months after trying to restart it again the engine would not start,what could be the problem and do I need to chance any parts after having it down for so long.

Thank you
Reply With Quote
Old 01-01-2011, 03:17 PM
Goat Herder's Avatar
Goat Herder Goat Herder is offline
Gutter Rider
Join Date: Apr 2008
Location: N.M.
Posts: 6,251
Default Re: engine not working

It could be that your fuel turned to varnish. Does it smell like varnish? Any way the bad fuel if any left needs to be removed. It is said that pre mix fuel is at its true optimum sitting for no more than two weeks.
Still gotta have a since of humor.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -5. The time now is 10:52 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.