SBP expansion chamber leaking from all seals

Discussion in 'Motorized Bicycle General Discussion' started by geoldr, Oct 15, 2011.

  1. geoldr

    geoldr New Member

    Joined:
    Jun 19, 2011
    Messages:
    260
    Likes Received:
    0
    Hey guys, so after installing my expansion chamber, I had to take it off once. After putting it back on, I used those black silicone things they provide, and I also used high temp sealant that I painted around it to seal. Now though, its leaking from 2 out of the 3 seals! It blew through the liquid stuff. I don't know how to fix this. I don't have a welder so I cant weld the thing. I can provide pictures tomorrow if necessary
     
  2. 5-7HEAVEN

    5-7HEAVEN Well-Known Member

    Joined:
    Aug 2, 2008
    Messages:
    2,364
    Likes Received:
    37
    You DID tighten up the clamps, yes?
     
  3. richirich

    richirich New Member

    Joined:
    Aug 16, 2011
    Messages:
    297
    Likes Received:
    0
    i used a mapp gas torch and soldering rod to seal the copper fittings.
     
  4. geoldr

    geoldr New Member

    Joined:
    Jun 19, 2011
    Messages:
    260
    Likes Received:
    0
    The exhaust came with 3 clamps. I used 2 on the big J-pipe to expansion chamber. And the last one on one of the small seals. Ill get more from the store and use them. I was actually thinking that.

    richrich, I only have a propane torch
     
  5. richirich

    richirich New Member

    Joined:
    Aug 16, 2011
    Messages:
    297
    Likes Received:
    0
    propane would work , it just takes alittle longer to heat it up
     

Share This Page