Problems tuning a Zeda Dio Reed build

Discussion in 'Motorized Bicycle Trouble Shooting' started by kelso, Apr 22, 2019.

  1. kelso

    kelso New Member

    Joined:
    Apr 21, 2019
    Messages:
    1
    Likes Received:
    1
    I recently started building a Zeda motorsports Dio Reed engine on a Specialized mountain bike.
    The build itself is complete and now I'm in the world of tuning. however I'm running into a bit of a wall getting this zed to run properly.... It has a 21mm OKO pwk carb and will ONLY RUNS WITH THE CHOKE ON. Choke off or down i can get a decent idle but it still "searches" here and there. how running it with the choke on (up) i can get it to run and up to speeds of around 30.... but it has zero power on any kind of incline. if i put the choke down it will bog out until it dies... I've put about 40 miles on it all with the choke on.... is she rich? is she lean? I'm getting signs from both worlds

    pilot jet is a 40
    needle is positon 2
    main jet 60.... currently best with small jet. tried 88, 90, 96,100,110,115 and 125.... 125 wouldn't even turn over once...

    I've played with the needle and the main jets.... nothing seems to be changing for better or worse. i thought it was rich but now I'm conflicting signs it could be leaning out...
    i posted pics of my setup below. any tips would be greatly appreciated !!

    problems it could be....
    1. dirty carb
    2. wrong jet
    3. air leak
    4. stock exhaust with upgraded carb
    5. bad seal/gaskets
    6. wrong mixture of gas currently 20:1 for breaking period
    7. float bowl
    IMG_1201.jpg IMG_1202.jpg IMG_1203.jpg IMG_1204.jpg IMG_1205.jpg
     
    #1 kelso, Apr 22, 2019
    Last edited: Apr 22, 2019
    fasteddy likes this.
  2. Venice Motor Bikes

    Venice Motor Bikes Custom Builder / Dealer/Los Angeles

    Joined:
    Mar 20, 2008
    Messages:
    6,572
    Likes Received:
    359
    It sounds like you need a slightly bigger pilot jet.

    Also... you have all your vent tubes blocked off.
    One is a float bowl vent... (that needs to be open to the air).
    One at the bottom of the bowl is a overflow tube
    Another at the bottom is a drain tube &
    another is probably a oil injection tube... (that needs to be blocked off)

    Post some close up pics of the carb tubes & we'll try to figure out what's what. (^)
     
    fasteddy likes this.
  3. Cbr_rider1000rr85

    Cbr_rider1000rr85 New Member

    Joined:
    May 16, 2020
    Messages:
    6
    Likes Received:
    0
    I just purchased the same engine 80cc dio Reed valve with the Oko carb just got it all installed and I'm having the same issue it don't wanna run and only runs with choke up (on) doesn't have any power. The place I bought it from sent me 3 different size jets for the carb I'm gonna try swopping em for the next size... If anybody can help us out we would greatly appreciate it. Thanks
     
  4. haXXsaw2012

    haXXsaw2012 New Member

    Joined:
    May 18, 2020
    Messages:
    2
    Likes Received:
    0
    Sounds like you have an air leak. Runs with choke on it's getting air somewhere and with no power it's not getting compression. Check your seals and head.
     
  5. Cbr_rider1000rr85

    Cbr_rider1000rr85 New Member

    Joined:
    May 16, 2020
    Messages:
    6
    Likes Received:
    0
    All the gaskets and seals are brand new... I did notice there is no windows piston installed in this engine, could that cause it to act like it's acting?
     
  6. Cbr_rider1000rr85

    Cbr_rider1000rr85 New Member

    Joined:
    May 16, 2020
    Messages:
    6
    Likes Received:
    0
     
  7. haXXsaw2012

    haXXsaw2012 New Member

    Joined:
    May 18, 2020
    Messages:
    2
    Likes Received:
    0
    I did read someone else saying for the Reed and oko it has huge volume and the window piston is necessary to bring that all into the engine.
     

Share This Page