Possible Speedo Fix

Discussion in 'Motorized Bicycle General Discussion' started by sketchman, May 13, 2011.

  1. sketchman

    sketchman New Member

    Joined:
    Mar 23, 2011
    Messages:
    168
    Likes Received:
    0
    I'm sure lots of people have the cheapo Wal-Mart Bell/Schwinn wired cycle computers.

    I just got one and it just doesn't seem to work very well at all. No matter how close to the sensor I get the magnet, it never reads correctly and is very slow to respond to changes. I even shut the engine off to rule out interference with no change. Also noticed the faster I go, the worse it gets. Sometimes showing zero when at full speed.

    What I found was that the magnet is pretty weak, and MAYBE not closing the circuit long enough to register. The faster you go the less chance it has to do it. Seems to make sense. So, I've ordered some neodynium discs that fit into the supplied plastic housing perfectly. I'm going to try it out and see what happens. If it works and anyone else wants some, they are super cheap at kjmagnetics.com.

    Order part #D63-N52 to fit the stock screw on plastic housing. If you're wondering, you just hold the plastic barrel and push on the screw and the whole thing just slides out.
     
  2. 2door

    2door Moderator
    Staff Member

    Joined:
    Sep 15, 2008
    Messages:
    16,304
    Likes Received:
    29
    Just wondering; There is a small, very hard to see arrow on the front of the magnetic pickup that attaches to the fork. If the magnet doesn't exactly line up, center, with that arrow you'll have the problems you describe. Even with the magnet very close, if it is above or below the arrow you'll get weird readings.
    Tom
     
  3. sketchman

    sketchman New Member

    Joined:
    Mar 23, 2011
    Messages:
    168
    Likes Received:
    0
    That is interesting. I feel stupid now, and will check that.
     
    #3 sketchman, May 14, 2011
    Last edited: May 14, 2011
  4. sketchman

    sketchman New Member

    Joined:
    Mar 23, 2011
    Messages:
    168
    Likes Received:
    0
    I can't believe it was that simple. Works fine now. Thanks.
     

Share This Page