just died,PLEASE HELP...??

Discussion in 'Introduce Yourself' started by vasago, Sep 5, 2015.

  1. vasago

    vasago New Member

    Joined:
    Aug 19, 2015
    Messages:
    5
    Likes Received:
    0
    maybe someone can help.? ok this is the deal, so I came to a red light n stoped. all seemed fine then all of a sudden the engine stalled that happenes sometimes so I thought nothing of it. thinking back it was almost like I let the clutch out to fast and stalled that's kinda how it was only it just died.. I checked everything I can think of with no luck. if anyone has any ideas or sugestions I would love to hear what you think...?
     
  2. 2door

    2door Moderator
    Staff Member

    Joined:
    Sep 15, 2008
    Messages:
    16,310
    Likes Received:
    38
    Welcome to the forum. You've found the right place for help with your motorized bicycle.

    We do ask that when seeking advice or answers to your questions that you tell us what engine you have. Troubleshooting gets much easier if we know what we're looking at.

    From your manual clutch reference we'll assume you have a Chinese 2 stroke engine. We have a troubleshooting section and it is headed by a very good tutorial that will give you a starting point on what to look for if the engine doesn't run. Here's a link to that thread > http://motorbicycling.com/showthread.php?t=35090

    Good luck and let us know what you find.

    Tom
     
  3. LongboardMalinois

    Joined:
    Jul 5, 2015
    Messages:
    128
    Likes Received:
    0
    I'm sure you checked this, but it didn't run out of gas, right? And the CDI wires are still connected. That is what happened to my bike one time, the cdi wires popped apart and i couldn't figure it out for a while.
    Good luck!
     
  4. bluegoatwoods

    bluegoatwoods Active Member

    Joined:
    Jul 29, 2012
    Messages:
    1,581
    Likes Received:
    1
    We're glad you joined up. There's help and info to be found here.

    2Door pointed you in an excellent direction. There's almost nothing more to be said.

    Still, LongboardMalinois also pointed you in a good direction. A loose wire is often the cause of what you've described.
     
  5. vasago

    vasago New Member

    Joined:
    Aug 19, 2015
    Messages:
    5
    Likes Received:
    0
    I found the problem, I blew my top end. I opened it up and found the rings shattered, gouges and scratches everywhere
     
  6. LongboardMalinois

    Joined:
    Jul 5, 2015
    Messages:
    128
    Likes Received:
    0
    I'm sorry to hear that! What do you think caused the rings to break? Maybe the piston is installed backwards? Get yourself a top end rebuild kit from Fred at CR Machine.com. His top end kits come pre ported, polished, and with the famous Fred Head! I have an increased compression fred head on mine, and the power increase is noticeable! Good luck with your engine!
     

Share This Page