After 200 miles of riding I hit a snag

Discussion in 'Introduce Yourself' started by lanemag, Apr 18, 2010.

  1. lanemag

    lanemag New Member

    Joined:
    Apr 18, 2010
    Messages:
    2
    Likes Received:
    0
    I recently purchased a raw 66cc bicycle engine kit and have put around 200 miles of use on it. I was riding the other day with my friend and the engine backfired once and the bike slowed to a stop and cut off. I tried to restart it but it was as if the piston was not getting any fire. So I bought a new spark plug and tried it but it still didn't work. I then tried my friends spark plug that we knew was identical to my previous one and it still didn't work. It's hard to explain the problem but when i drop the clutch the engine turns over as long as I pedal but it won't kick on. When I give it gas it sounds like it is trying to get going but can't almost as if its flooding but I checked carburetor and it was fine. Not sure what the problem is can anyone point me in the right direction?
     
  2. professor

    professor New Member

    Joined:
    Oct 14, 2009
    Messages:
    501
    Likes Received:
    0
    A back fire occurs on lean mixture. Plugged gas cap vent? Plugged fuel filter?
    Welcome to Motorbicycling!
     
  3. Alabama Fisherman

    Alabama Fisherman New Member

    Joined:
    Apr 17, 2010
    Messages:
    7
    Likes Received:
    0
    A backfire can also occur when you have fire (spark) then it cuts out and fires again. I'd also check the magneto CDI and wire and boot.
     
  4. Bikeguy Joe

    Bikeguy Joe Godfather of Motorized Bicycles

    Joined:
    Jan 8, 2008
    Messages:
    11,529
    Likes Received:
    4
    Check the key on the flywheel.
     
  5. lanemag

    lanemag New Member

    Joined:
    Apr 18, 2010
    Messages:
    2
    Likes Received:
    0
    I know that the gas cap and fuel filter are not plugged because I thought the same thing and made sure they weren't. Also, Bikeguy Joe and Alabama Fisherman, could you go into a litter more detail on how I would check and/or fix those problems?
     
    #5 lanemag, Apr 19, 2010
    Last edited: Apr 19, 2010

Share This Page