Search results

  1. T

    Bike runs fine but hard to petal when after use

    I recently purchased a bike it worked fine until now, it petals fine and starts but once I turn it off and start it again it becomes harder and harder to petal. Could this be because of the heat? Once it cools down/sits it becomes normal how do I prevent this
  2. T

    Chain comes off sprocket before tensioner

    When I move the bike the chain just comes off of the sprockets once it’s at a certain point and the more I move it gradually comes off more (it starts to come off where the tensioner is) what should I do
  3. T

    Chain keeps coming off

    When I move the bike the chain just comes off of the sprockets once it’s at a certain point and the more I move it gradually comes off more (it starts to come off where the tensioner is) what should I do
  4. T

    Bike makes noise but won’t turn over

    I just purchased this bike it worked when I tested it but now when I petal and let go of the clutch you hear the bike make noise but the engine won’t kick in if that makes sense. The only thing I noticed was the ground wire is kind of free, could that be the problem any suggestions?
  5. T

    Bike won’t turn over

    I just purchased this bike it worked when I tested it but now when I petal and let go of the clutch you hear the bike make noise but the engine won’t kick in if that makes sense. The only thing I noticed was the ground wire is kind of free, could that be the problem any suggestions?