Search results

  1. Mars4

    Clutch issue

    Rings are fine everything looks normal inside. I don't get it. I ordered new rings just to try
  2. Mars4

    Clutch issue

    Ok I'll post what I find
  3. Mars4

    Clutch issue

    I think I should get a new Piston and rings and try that
  4. Mars4

    Clutch issue

    I agree Im new to these engines. I'm not sure how to fix it. But I'd like to try instead of replacing it
  5. Mars4

    Clutch issue

    It came all together I can see the rings through the carb port
  6. Mars4

    Clutch issue

    Would that be like new rings or something
  7. Mars4

    Clutch issue

    That's what I was starting to think. How do I fix the compression? Any ideas
  8. Mars4

    Clutch issue

    The big gear and the small gear and the clutch plate. I can hear the Piston pumping
  9. Mars4

    Clutch issue

    this is with the motor not running the bike just sitting there I can push it freely without squeezing the clutch
  10. Mars4

    Clutch issue

    Maybe I'm wrong but that's how the other bike is that I built
  11. Mars4

    Clutch issue

    the sprocket that the chain is attached to is not supposed to turn unless you squeeze the clutch.mine turns no matter what whether you squeeze a clutch or let go of the clutch
  12. Mars4

    Clutch issue

    Yes it is strange I'm at a loss not sure what to do. I'll keep at it
  13. Mars4

    Clutch issue

    I can turn the small great with my hand and it moves the Piston up and down.
  14. Mars4

    Clutch issue

    Thanks I tried that also. Took the entire clutch apart checked spring and put it back together still doing it. The spring on the shaft was so tight loosened it. A little better but still rolls without pressing clutch
  15. Mars4

    Clutch issue

    I've tried loose, tight it still rolls
  16. Mars4

    Clutch issue

    I also disconnected the clutch cable completely and the bike and chain still roll
  17. Mars4

    Clutch issue

    Adjusted it same issue
  18. Mars4

    Clutch issue

    The clutch engages but when I let go it still rolls like it's engaged when it isn't
  19. Mars4

    Clutch issue

    Just got new motor from eBay this is my second build. The bike rolls freely when I press clutch and release it. It always rolls freely. Removed all 3 sprockets to check the keys all fine. Still does the same thing not sure what to do