Motorized Bicycle Engine Kit Forum  


Go Back   Motorized Bicycle Engine Kit Forum > Motorized Bicycle > Motorized Bicycle General Discussion

Motorized Bicycle General Discussion All topics regarding bicycles with engines.

Thread Tools Display Modes
Old 07-10-2008, 01:17 AM
billyjoebigdaddy billyjoebigdaddy is offline
Motorized Bicycle Newbie
Join Date: May 2008
Posts: 9
Question clutch

A couple of times my clutch would not work. I would pull it in and the engine was still engaged. However after the engine was stopped the clutch worked again. And also the last time it did it the clutch started making a squeaking noise. Anyone with an idea what would cause the clutch not to engage but works after the engine is stopped and restarted?
Reply With Quote
Old 07-10-2008, 04:00 AM
stude13 stude13 is offline
Motorized Bicycle Elite Member
Join Date: May 2008
Location: north bend wa.
Posts: 404
Default Re: clutch

hi bjbd; welcome to the most informative site in the world. we have talked and can see no resolution to your problem. give it up. ride on--are you from texas? mitch
Reply With Quote
Old 07-10-2008, 07:23 AM
Bikeguy Joe Bikeguy Joe is offline
Godfather of Motorized Bicycles
Join Date: Jan 2008
Location: up north now
Posts: 11,531
Default Re: clutch

Well does it not engage or not dis-engage? You've stated both.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -5. The time now is 06:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.