Motorized Bicycle Engine Kit Forum  


Go Back   Motorized Bicycle Engine Kit Forum > Motorized Bicycle > Motorized Bicycle General Discussion

Motorized Bicycle General Discussion All topics regarding bicycles with engines.

Thread Tools Display Modes
Old 10-10-2009, 01:03 AM
Junster's Avatar
Junster Junster is offline
Motorized Bicycle Elite Member
Join Date: Jun 2009
Location: Washington St.
Posts: 446
Default Bad Luck Good Luck

Well about 3 weeks ago I broke my frame. Just above the front motor mount. Put a sleeve over it and started looking for a new frame. Then about a week ago I started losing power and the motor started getting hot. Tore it down and one of the ring alignment pins had come out and gouged the cylinder wall. Then I found a new GT frame on craigslist for 20 bucks. (The good luck) I had some work to do on the new frame, the bottom bearings were toast. I ended up welding a big nut on the right side bearing cup and using a air impact to get it off. The reason it was so bad? Someone had removed the water bottle carrier and not plugged the holes. The bike had sat outside and let water get inside the frame and run into the bottom bracket. The new frame is finshed and ridable. Just waiting on a new jug piston and rings from Dax. Here's a couple pics and one showing the frame holes plugged with 2, 5mm set screws.





Put something FUN between your legs..
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -5. The time now is 03:52 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.