View Single Post
Old 07-22-2009, 06:38 PM
upsrogue upsrogue is offline
Motorized Bicycle Member
Join Date: Jul 2009
Location: Arizona
Posts: 23
Default Re: Schwinn Landmark Front Tube Size

Hi I have the bike and did a install about 2 weeks ago with a 49cc 2 stroke China girl

I don't know what a "front mount kit" is so I don't know if you need to order one or not.

But yes I had a problem with the front mount because the frame tube on the Landmark is to big around and will not fit between the two studs that come out of the front of engine, I made a set up that works for me using a car muffler clamp and a piece of 1/2" square tubing I just had to drill 4 holes in the square tubing, no welding.

I will check to see if I made pics of the set up or not I will show you what it "might look like"

The rear engine mount works perfect that comes with the engine, the other problem I had was mounting the chain tensioner, the bar it mounts on is too small so you can't tighten it down enough and it wants to turn in toward the wheel when under tension, after one badly bent wheel, so I did away with the tensioner by shorting the chain so when I need to take the chain off I just remove the master link on the chain. Check other threads for fixes if you want to keep the tensioner on, just don't put it on out of the box it will cost you a wheel.

I will get back to you here.
Attached Images
File Type: jpg new bike.JPG (102.2 KB, 133 views)

Last edited by upsrogue; 07-22-2009 at 06:49 PM. Reason: to add info
Reply With Quote