View Single Post
Old 11-21-2012, 11:52 PM
gunslingerburrito gunslingerburrito is offline
Motorized Bicycle Member
Join Date: Sep 2011
Location: Gulfport, MS
Posts: 41
Default Just need a new motor?

The bike was running fairly well until a few months ago.

It seemed to get gradually harder to get up to speed, and it almost seemed like it was bogging.

I leaned it out, and that didn't do much. Which was odd, since this normally had a good effect on the performance.

I tried a different oil.
No change.

I tried a new carb out of curiosity.
I forgot to plug up the air leaks, and it idled at scary-high rpm's for about 10 seconds until I could stop and kill the motor.

Then, it stopped cranking completely.

It would almost crank when I would pedal in gear, but instantly died when I'd pull in the clutch.

I tried a new magneto, thinking it wasn't getting a spark.
No change.

Ditto with a new CDI.

So, today I pulled the head and the cylinder.
I'll reply with pics after thanksgiving, but here's what I saw.

First, there was a ton of carbon build up on the top of the piston and the firing cup in the head.

The cylinder was mirror smooth. No scratches on either the piston or the cylinder walls.

The piston had a brown burned looking patch on one side (guessing that's not good).

The cylinder also had a lot of side to side play from the bottom of the connecting rod up.

So, my questions are:

A) What does that sound like to you?
B) Can it be fixed?

And most importantly:
C) would it be cheaper/easier to just buy a new engine?

This is a 58cc Grubee Starfire Gen-II A.
It's a year old, and has a lot of miles on it.

Thanks guys, and happy thanksgiving!
Reply With Quote