View Single Post
Old 07-31-2008, 07:02 PM
fritzalee fritzalee is offline
Motorized Bicycle Newbie
Join Date: Jul 2008
Posts: 13
Default Hello from NE Florida

Thought I would introduce myself, as I have been lurking in the backgound for a few weeks. I am a semi retired A/C, refrigeration contractor, and can't stand not having something to tinker with. Came across this forum just goofing around on a new computer, thought what the heck buy a kit and try it on that 21 speed Roadmaster that I purchased in 1996, and still has the nubbies on the tires. Well $182.00, and a 9 day wait I recieved my kit from boysgofast on Ebay. The package was packed well, triple boxed, with USA cardboard on the outer box, everything that was supposed to be there, was.
I assembed the kit on my bike without too much trouble, "of course all of you folks had figured out where and how for me", I did strip the threads on the fuel petcock, tried JB Weld but it's starting to leak, maybe I didn't let it cure long enough, looking for a brass replacement. The instructions for starting said to start going down hill, (BOY) where they right, these old legs were starting to shake before she fired up, seems to run smooth needs to be run some more for the brake in period, have no idea how fast it will go just running at half throutle. Looking at a Bell wireless speedometer at WalMart, any feed back would be appreciated.
Thank you-all for your input on this forum, without this wealth of information I would still be trying to assemble the sprocket.
Reply With Quote