View Single Post
Old 06-02-2010, 01:15 AM
GearNut's Avatar
GearNut GearNut is offline
Motorized Bicycle Elite Member
Join Date: Aug 2009
Location: San Diego, Kaliforgnia
Posts: 5,106
Default Re: where can I find the answer on here

If your spark plug is a milky brown then you are good to go for an engine that is broken in.
Since yours is still in the break in mileage, I would like to see it more like a dark chocolate brown. This slightly rich fuel/ air ratio insures that there is a little bit extra oil getting to the engine's internals and it burns a bit cooler than a leaner ratio.
The too big of a jet syndrome leans towards a very rich fuel/ air ratio, which would make the spark plug black in color. This also causes "4 stroking". This may still be possible in your case and will only show up during 3/4 to full throttle operation.
I now suspect that you may have a bad spark plug or spark plug wire. Either of these problems will cause poor operation at higher engine speeds. With all the previous questions and checks, we have pretty much ruled out carburetor jetting and oil ratio problems.
Oh yeah I almost forgot, are you using the stock plug in wire connectors between the engine wires and CDI wires? Those are notorious for being a problem. If so, suspect them before a bad plug or plug wire. Solder them and use electrical tape, or for the best job use heat shrink tubing, to seal and insulate them.
"It's a chinagirl. It's a sometimes fun little engine that often will break your heart. It's disposable.

Does not come with a fortune cookie."

Last edited by GearNut; 06-02-2010 at 01:18 AM.
Reply With Quote