View Single Post
Old 06-01-2010, 12:32 PM
bairdco's Avatar
bairdco bairdco is offline
a guy who makes cool bikes
Join Date: Aug 2009
Location: living the dream in southern california
Posts: 6,262
Default Re: 42 miles of He.....

everytime someone has a problem with their kit, everyone else jumps in with their problems, and then they decide that it's the kit, and not the installer.

now, i'm not saying it isn't the kit, but i've seen these exact posts no matter what engine they're talking about.

i've also seen a lot of people who have the same kit and have nothing but praise for it.

as for the original poster's problems, sounds like all the "mods" you've done to your motor are the problem. it's really easy to get carried away, especially if you don't know what you're doing, or haven't done it before.

there's is such a thing as "too much" when it comes to porting, where a few millimeters too far could give some bad results, or it could be that you made your motor need more that the carb allows.

once you get into "performance" mods, one step at a time is the way to go. if you did everything you said at one time, for the first time, without knowing what works and what doesn't, then you'll have no idea what's causing things to go wrong.

it could also be a simple as bad fuel, wrong float level, airleak, crappy plug and/or wire, loose connections at the terminals...

finally, even if it's a bad motor right from the start, since you modded it out, you'll never know, and your warranty is void.

next time, assuming you don't give up on these motors, i suggest running it bone stock for a month till it's broken in, then start tricking it out, one step at a time.
Reply With Quote