View Single Post
Old 07-06-2008, 08:01 PM
Motorized Bicycle Member
Join Date: May 2008
Location: Arab Al. (close to Huntsville Al.
Posts: 41
Default Re: Goodbye from Florida

think we all newbies have those problems,,,, got mine installed and started like a charm in about 50 feet,,,, rode it about a mile lost a chain... put it back on going home lost it again but this time also lost master lnk,,,ugggg take chain off and peddle it home .... go next day get new link put it all back together and off i go again .... goes good for a few days .. as im looking at it with the guys at work i notice the bolts on the back sprocket are "all" loose and one is missing.... during lunch i retighten them and find a replacement nut.... going good for a cpl more days then take bike to my mothers house to show famile and friends there,,, ride most all day no problems,,, ok time to go home so one more ride.. BOOM chain breaks and wraps arond back spokes.. i slide to a halt .... with out crashing... so i untangle chain pick up the pieces on the ground,,, chain is now broke and bent and warp all to he** ,,, so on the way home i stop at TRACTOR SUPPLY buy a box of chain (thanx guys ) and get it back going again ,,, no problems so far .... except one (my fault) i go to work one morning ... i get going and it jus stops ... gas is going all down the frame and my leg.... i look closly and see i knock the fule line off as i was taking off the choke .... no problems.. put it back on and go .... THEY AINT FOR EVERY ONE ILL GIVE THEM THAT .. but i have enjoyed it ALL .... and look forward to more ridding ,,,
ride on yall

Last edited by RONNY_ODELL; 07-06-2008 at 08:09 PM.
Reply With Quote